Несколько уязвимостей в OpenAFS

Дата публикации:
09.04.2009
Дата изменения:
09.04.2009
Всего просмотров:
1746
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1250
CVE-2009-1251
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenAFS 1.x
Уязвимые версии:
OpenAFS 1.4.8 и более ранние версии.
OpenAFS 1.5.58 и более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в OpenAFS клиенте. Удаленный пользователь может с помощью специально сформированного пакета вызвать переполнение динамической памяти и выполнить произвольный код на системе в пространстве ядра. Уязвимость распространяется на все Unix клиенты, за исключением клиентов для Mac OS X 10.4 и 10.5.

2. Уязвимость существует из-за ошибки в OpenAFS, которая позволяет спровоцировать использование кодов ошибок сервера в качестве указателей. Удаленный пользователь может с помощью специально сформированных пакетов аварийно завершить работу Linux cache manager и вызвать панику ядра системы.

URL производителя: www.openafs.org

Решение: Установите последнюю версию 1.4.9 или 1.5.59 с сайта производителя.

Ссылки: http://www.openafs.org/security/OPENAFS-SA-2009-001.txt
http://www.openafs.org/security/OPENAFS-SA-2009-002.txt

или введите имя

CAPTCHA