Множественные уязвимости в Bloginator

Дата публикации:
03.04.2009
Дата изменения:
03.04.2009
Всего просмотров:
1712
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1049
CVE-2009-1050
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Bloginator 1.x
Уязвимые версии: Bloginator 1A, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за того, что приложение разрешает доступ к административному интерфейсу при наличии определенного параметра в файле куки. Удаленный пользователь может установить параметр "identifyYourself" в произвольное значение и получить административный доступ к приложению.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "id" в сценарии articleCall.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: kamads.com/kamads_ads/bloginator.php

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Bloginator v1a SQL Command Injection via Cookie Bypass Exploit
http://milw0rm.com/exploits/8243

или введите имя

CAPTCHA