Множественные уязвимости в Little cms

Дата публикации:
03.04.2009
Дата изменения:
03.04.2009
Всего просмотров:
2044
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-0581
CVE-2009-0723
CVE-2009-0733
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Little cms 1.x
Уязвимые версии: Little cms версии до 1.18

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в функции "ReadSetOfCurves()" при обработке изображений. Удаленный пользователь может с помощью специально сформированного изображения вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Целочисленное переполнение существует из-за ошибки при обработке изображений. Удаленный пользователь может с помощью специально сформированного изображения вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

3. Уязвимость существует из-за утечки памяти при обработке изображений. Удаленный пользователь может с помощью специально сформированного изображения потребить всю доступную память на системе и вызвать отказ в обслуживании.

URL производителя: www.littlecms.com

Решение: Установите последнюю версию 1.18 с сайта производителя.

Ссылки: http://scary.beasts.org/security/CESA-2009-003.html

или введите имя

CAPTCHA