Множественные уязвимости в Pixie CMS

Дата публикации:
02.04.2009
Дата изменения:
02.04.2009
Всего просмотров:
2067
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1065
CVE-2009-1066
CVE-2009-1067
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Pixie CMS 1.x
Уязвимые версии: Pixie CMS 1.01a, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "x" в сценарии index.php, когда параметр "s" установлен в значение "blog" и параметр "m" равен "permalink". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в HTTP заголовке "Referer" в функции "referral()" в сценарии admin/lib/lib_logs.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "x" в сценарии index.php, когда параметр "s" установлен в значение "blog" и параметр "m" равен "permalink". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.getpixie.co.uk

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://lampsecurity.org/Pixie-CMS-Multiple-Vulnerabilities

или введите имя

CAPTCHA