Целочисленное переполнение в GLib

Дата публикации:
24.03.2009
Дата изменения:
24.03.2009
Всего просмотров:
1763
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNOME GLib 2.x
Уязвимые версии: GLib версии до 2.20.0

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Целочисленное переполнение обнаружено в функциях "g_base64_encode()" и "g_base64_decode()" в файле glib/base64.c. Удаленный пользователь может с помощью специально сформированных данных вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: developer.gnome.org/arch/gtk/glib.html

Решение: Установите последнюю версию 2.20.0 с сайта производителя.

Ссылки: http://www.ocert.org/advisories/ocert-2008-015.html

или введите имя

CAPTCHA