Множественные уязвимости в Foxit Reader

Дата публикации:
11.03.2009
Дата изменения:
19.03.2009
Всего просмотров:
4987
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-0191
CVE-2009-0836
CVE-2009-0837
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Foxit Reader 2.x
Foxit Reader 3.x
Уязвимые версии: Foxit Reader 3.0 и более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки при обработке JBIG2 сегментов. Удаленный пользователь может с помощью специально сформированного PDF файла вызвать разыменование неинициализированной памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных при обработке действий, указанных в PDF файле. Удаленный пользователь может с помощью специально сформированного PDF файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.foxitsoftware.com/pdf/rd_intro.php

Решение: Установите последнюю версию 3.0 Build 1506 или 2.3 Build 3902 с сайта производителя.

Журнал изменений:

19.03.2009
Добавлен PoC код.

Ссылки: Secunia Research: Foxit Reader JBIG2 Symbol Dictionary Processing Vulnerability
CORE-2009-0218: Foxit Reader Multiple Vulnerabilities
Foxit Reader 3.0 (<= Build 1301) PDF Buffer Overflow Exploit
http://www.foxitsoftware.com/pdf/reader/security.htm

или введите имя

CAPTCHA