Межсайтовый скриптинг в Drupal Protected Node Module

Дата публикации:
05.03.2009
Дата изменения:
05.03.2009
Всего просмотров:
2090
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Protected Node Module 5.x
Уязвимые версии: Drupal Protected Node Module 5.x-1.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "protected_node_info" в сценарии index.php, когда параметр "q" установлен в значение "admin/settings/protected_node". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре специально сформированной страницы входа. Для успешной эксплуатации уязвимости требуются привилегии "administer site configuration".

URL производителя: drupal.org/project/protected_node

Решение: Установите последнюю версию 5.x-1.4 с сайта производителя.

Ссылки: http://lampsecurity.org/node/28

или введите имя

CAPTCHA