Спуфинг атака в eid Middleware

Дата публикации:
05.03.2009
Дата изменения:
05.03.2009
Всего просмотров:
1469
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
eid Middleware 2.x
Уязвимые версии: eid Middleware 2.6.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести спуфинг атаку.

Уязвимость существует из-за того, что библиотека некорректно проверяет возвращаемые значения OpenSSL функцией "EVP_VerifyFinal()". Удаленный пользователь может с помощью специально сформированной SSL/TLS подписи для DSA и ECDSA ключей обойти проверку подлинности сертификатов.

URL производителя: eid.belgium.be

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.ocert.org/advisories/ocert-2008-016.html