Множественные уязвимости в BarnOwl

Дата публикации:
04.03.2009
Дата изменения:
04.03.2009
Всего просмотров:
1577
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BarnOwl 1.x
Уязвимые версии: BarnOwl версии до 1.0.5

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в функции "GetZephyrVarKeyFile()" в файле zcrypt.c. Удаленный пользователь может с помощью специально сформированного "zcrypt" сообщения вызвать переполнение буфера и выполнить произвольный код на целевой системе.

2. Переполнение буфера обнаружено в функциях "owl_zwrite_send_ping()", "owl_zwrite_set_message()" и "owl_zwrite_send_message()" в файле zwrite.c. Удаленный пользователь может с помощью специально сформированной команды "reply" для сообщений с определенными Zephyr CC: списками вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: barnowl.mit.edu

Решение: Установите последнюю версию 1.0.5 с сайта производителя.

Ссылки: http://barnowl.mit.edu/wiki/barnowl-1.0.5-announce
http://barnowl.mit.edu/browser/ChangeLog

или введите имя

CAPTCHA