Переполнение буфера в ksquirrel-libs

Дата публикации:
03.03.2009
Дата изменения:
03.03.2009
Всего просмотров:
1864
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ksquirrel-libs 0.x
Уязвимые версии: ksquirrel-libs 0.8.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "mt_codec::getHdrHead()" в файле kernel/kls_hdr/fmt_codec_hdr.cpp. Удаленный пользователь может с помощью специально сформированного Radiance RGBE (*.hdr) файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: ksquirrel.sourceforge.net/subprojects.php

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA