SQL-инъекция в OpenSite

Дата публикации:
03.03.2009
Дата изменения:
03.03.2009
Всего просмотров:
2305
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenSite 2.x
Уязвимые версии: OpenSite 2.1, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в индексах массива "permissions[]" в сценарии admincp/includes/functions.php, когда параметр "do" установлен в значение "save" и параметр "action" равен "edit". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "settings[site_name]", "settings[main_page]" и "settings[enableplugins]" в сценарии admincp/settings.php, когда параметр "do" установлен в значение "save". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: sourceforge.net/projects/opensitecms/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.bluemoon.com.vn/advisories/bmsa200903.html

или введите имя

CAPTCHA