PHP-инклюдинг в YACS

Дата публикации:
01.03.2009
Дата изменения:
01.03.2009
Всего просмотров:
2396
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
YACS 8.x
Уязвимые версии: YACS 8.11rc30, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "context[path_to_root]" в сценарии scripts/update_trailer.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/scripts/update_trailer.php?context[path_to_root]=[file]

URL производителя: www.yetanothercommunitysystem.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/8066

или введите имя

CAPTCHA