Отказ в обслуживании в Poppler

Дата публикации:
28.02.2009
Дата изменения:
28.02.2009
Всего просмотров:
1336
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
poppler 0.x
Уязвимые версии: Poppler версии до 0.10.4

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести DoS атаку.

1. Уязвимость существует из-за ошибки доступа к неинициализированной памяти в функции "FormWidgetChoice::loadDefaults()". Удаленный пользователь может с помощью специально сформированного PDF файла аварийно завершить работу приложения.

2. Уязвимость существует из-за ошибки в функции "JBIG2Stream::readSymbolDictSeg()". Удаленный пользователь может с помощью специально сформированного PDF файла аварийно завершить работу приложения.

URL производителя: poppler.freedesktop.org

Решение: Установите последнюю версию 0.10.4 с сайта производителя.

Ссылки: https://bugs.edge.launchpad.net/poppler/+bug/321764
https://bugs.edge.launchpad.net/poppler/+bug/320181

или введите имя

CAPTCHA