Межсайтовый скриптинг в Drupal Views Bulk Operations Module

Дата публикации:
26.02.2009
Дата изменения:
26.02.2009
Всего просмотров:
2135
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Views Bulk Operations Module 5.x
Drupal Views Bulk Operations Module 6.x
Уязвимые версии: Drupal Views Bulk Operations Module версии до 5.x-1.3 и 6.x-1.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в функции "theme_views_bulk_operations_confirmation()" в "views_bulk_operations.module" при обработке названий узлов. Удаленный пользователь может с помощью специально сформированного названия узла выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: drupal.org/project/views_bulk_operations

Решение: Установите последнюю версию 5.x-1.3 или 6.x-1.4 с сайта производителя.

Ссылки: http://drupal.org/node/369223

или введите имя

CAPTCHA