Подмена сертификатов в Ruby

Дата публикации:
26.02.2009
Дата изменения:
26.02.2009
Всего просмотров:
1742
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby 1.8.x
Ruby 1.9.x
Уязвимые версии: Ruby версии 1.8.x, 1.9.x

Описание:
Уязвимость позволяет удаленному пользователю произвести спуфинг атаку.

Уязвимость существует из-за того, что Ruby некорректно проверяет возвращаемое значение OpenSSL функцией "OCSP_basic_verify()". Удаленный пользователь может заставить приложение принять некорректный X.509 сертификат.

URL производителя: www.ruby-lang.org/en/

Решение: Установите исправление из репозитория производителя.

Ссылки: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513528
http://redmine.ruby-lang.org/issues/show/1091

или введите имя

CAPTCHA