Отказ в обслуживании в Yaws

Дата публикации:
26.02.2009
Дата изменения:
24.03.2009
Всего просмотров:
1887
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Yaws 1.x
Уязвимые версии: Yaws версии до 1.80

Описание:
Уязвимость позволяет удаленному пользователю произвести DoS атаку.

Уязвимость существует из-за ошибки при обработке запросов, содержащих большое количество заголовков. Удаленный пользователь может с помощью специально сформированного запроса аварийно завершить работу Web сервера.

URL производителя: yaws.hyber.org

Решение: Установите последнюю версию 1.80 с сайта производителя.

Журнал изменений:

17.03.2009
Добавлен PoC код.

Ссылки: Yaws < 1.80 (multiple headers) Remote Denial of Service Exploit

или введите имя

CAPTCHA