Повреждение памяти в libpng

Дата публикации:
19.02.2009
Дата изменения:
04.03.2009
Всего просмотров:
2879
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libpng 1.x
Уязвимые версии: libpng версии до 1.0.43 и 1.2.35

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за того, что библиотека некорректно инициализирует определенные массивы указателей перед освобождением элементов массивов в случае, когда приложение потребляет всю доступную память. Удаленный пользователь может с помощью специально сформированного PNG файла вызвать повреждение памяти и выполнить произвольный код на целевой системе.

URL производителя: www.libpng.org/pub/png/libpng.html

Решение: Установите последнюю версию 1.0.43 или 1.2.35 с сайта производителя.

Ссылки: http://sourceforge.net/mailarchive/message.php?msg_name=e56ccc8f0902181726i200f4bf0n20d919473ec409b7%40mail.gmail.com
http://www.kb.cert.org/vuls/id/649212

или введите имя

CAPTCHA