Повреждение памяти в FFmpeg

Дата публикации:
17.02.2009
Дата изменения:
17.02.2009
Всего просмотров:
2276
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FFmpeg 0.x
Уязвимые версии: FFmpeg 0.x

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за знаковой ошибки в функции fourxm_read_header() в файле libavformat/4xm.c. Удаленный пользователь может с помощью специально сформированного 4xm файла вызвать повреждение памяти и выполнить произвольный код на целевой системе.

URL производителя: ffmpeg.sourceforge.net/index.php

Решение: Установите исправление из SVN репозитория производителя.

Ссылки: http://www.trapkit.de/advisories/TKADV2009-004.txt

или введите имя

CAPTCHA