Множественные уязвимости в Horde

Дата публикации:
13.02.2009
Дата изменения:
09.04.2009
Всего просмотров:
2003
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-0931
CVE-2009-0932
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Horde Application Framework 3.x
Horde Groupware 1.x
Уязвимые версии:
Horde Application Framework версии до 3.2.4 и 3.3.3
Horde Groupware версии до 1.1.5

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценарии horde/services/portal/cloud_search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии framework/Image/Image.php. Удаленный пользователь может с помощью специально сформированного запроса просмотреть содержимое произвольных файлов на системе.

URL производителя: www.horde.org

Решение: Установите последнюю версию с сайта производителя.

Ссылки: http://lists.horde.org/archives/announce/2009/000483.html
http://lists.horde.org/archives/announce/2009/000482.html
http://lists.horde.org/archives/announce/2009/000486.html

или введите имя

CAPTCHA