PHP-инклюдинг в FlatnuX CMS

Дата публикации:
06.02.2009
Дата изменения:
26.02.2009
Всего просмотров:
2928
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FlatnuX CMS
Уязвимые версии: FlatnuX CMS 2009-02-04, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "_FNROOTPATH" в сценариях include/flatnux.php и filemanager.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена и опция "magic_quotes_qpc" отключена в конфигурационном файле PHP. Пример:

http://[host]/index.php?_FNROOTPATH=[file]%00

URL производителя: www.flatnux.altervista.org

Решение: Установите последнюю версию 2009-02-06.2 с сайта производителя.

Журнал изменений:

26.02.2009
Изменена секция «Решение».

Ссылки: http://milw0rm.com/exploits/7969

или введите имя

CAPTCHA