SQL-инъекция в 4Site CMS

Дата публикации:
06.02.2009
Дата изменения:
06.02.2009
Всего просмотров:
2148
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
4Site CMS 2.x
Уязвимые версии: 4Site CMS 2.6, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "login" и "password" в сценарии pcgi/4site.pl. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "page" в сценарии print/print.shtml. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "s" и "i" в сценарии portfolio/index.shtml. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

4. Уязвимость существует из-за недостаточной обработки входных данных в параметре "th" в сценарии faq/index.shtml. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.4site.ru

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://wsec.ru/wsec-09-002-4site-cms-26-multiple-sql-injections/

или введите имя

CAPTCHA