Переполнение буфера в FeedDemon

Дата публикации:
05.02.2009
Дата изменения:
13.02.2009
Всего просмотров:
2231
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FeedDemon 2.x
Уязвимые версии: FeedDemon 2.7, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке OPML файлов. Удаленный пользователь может с помощью специально сформированного OPML файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.newsgator.com/NGOLProduct.aspx?ProdId=FeedDemon

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

13.02.2009
Добавлен PoC код.

Ссылки: FeedDemon <=2.7 OPML Outline Tag Buffer Overflow Exploit
http://security.bkis.vn/?p=329

или введите имя

CAPTCHA