Множественные уязвимости в Bugzilla

Дата публикации:
05.02.2009
Дата изменения:
05.02.2009
Всего просмотров:
1665
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Bugzilla 3.x
Уязвимые версии: Bugzilla версии до 3.2.2 и 3.3.3

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за того, что приложение позволяет загружать HTML и JavaScript вложения. Удаленный пользователь может выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Уязвимость распространяется на версии 3.0.7, 3.2.1 и 3.3.2.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF нападение и внести изменения посредством сценария process_bug.cgi. Уязвимости подвержены версии 3.2.1 и 3.3.2.

3. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF нападение (изменить настройки, удалить результаты предыдущего поиска). Уязвимости повержены версии 3.0.7, 3.2.1 и 3.3.2.

4. Уязвимость существует из-за того, что приложение использует функцию srand() во время компиляции, если используется "mod_perl". Удаленный пользователь может угадать значение токена и произвести CSRF нападение или получить доступ к потенциально важным данным через функционал "attachment_base".

URL производителя: www.bugzilla.org/releases/3.0/

Решение: Установите последнюю версию 3.2.2 или 3.3.3 с сайта производителя.

Ссылки: http://www.bugzilla.org/security/3.0.7/

или введите имя

CAPTCHA