Межсайтовый скриптинг в D-Link DVG-2001S

Дата публикации:
05.02.2009
Дата изменения:
05.02.2009
Всего просмотров:
2136
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
D-Link DVG-2001S VoIP Phone Adapter
Уязвимые версии: D-Link DVG-2001S VoIP Phone Adapter 1.00.007, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в URL в Forms/page_CfgDevInfo_Set. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF нападение и загрузить произвольную прошивку на устройство.

URL производителя: www.dlink.com/products/?pid=447

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: D-Link VoIP Phone Adapter XSS/XSRF Remote Firmware Overwrite

или введите имя

CAPTCHA