Выполнение произвольных команд в FhImage

Дата публикации:
04.02.2009
Дата изменения:
04.02.2009
Всего просмотров:
1545
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FhImage 1.x
Уязвимые версии: FhImage 1.2.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной проверки входных данных в сценарии imgconfig/index.php перед сохранением данных в файл settings.php. Удаленный пользователь может внедрить и выполнить произвольный PHP код на целевой системе с привилегиями Web сервера. Для успешной эксплуатации уязвимости злоумышленнику потребуется доступ к каталогу "imgconfig".

URL производителя: www.flash-here.com/downloads/fhimage.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Fhimage 1.2.1 Remote Command Execution Exploit
Fhimage 1.2.1 Remote Index Change Exploit

или введите имя

CAPTCHA