Межсайтовый скриптинг в Apache Jackrabbit

Дата публикации:
03.02.2009
Дата изменения:
03.02.2009
Всего просмотров:
2336
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache Jackrabbit 1.x
Уязвимые версии: Apache Jackrabbit 1.5.0 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "q" в сценариях search.jsp и swr.jsp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: jackrabbit.apache.org

Решение: Установите последнюю версию 1.5.2 с сайта производителя.

Ссылки: https://issues.apache.org/jira/browse/JCR-1925

или введите имя

CAPTCHA