PHP-инклюдинг в GNUBoard

Дата публикации:
30.01.2009
Дата изменения:
30.01.2009
Всего просмотров:
3013
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNUBoard 4.x
Уязвимые версии: GNUBoard 4.31.03, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "g4_path" в сценарии common.php. Удаленный пользователь может с помощью специально сформированного "data:" URI выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опции "register_globals" и "allow_url_include" должны быть включены в конфигурационном файле PHP. Пример:

http://[host]/common.php?g4_path=../../../../../../etc/passwd%00

URL производителя: www.sir.co.kr

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/7792

или введите имя

CAPTCHA