SQL-инъекция в Drupal

Дата публикации:
30.01.2009
Дата изменения:
30.01.2009
Всего просмотров:
2046
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 5.x
Drupal 6.x
Уязвимые версии: Drupal версии до 5.15 и 6.9

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в Node Access API. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Удачная эксплуатация уязвимости требует наличие другого модуля на системе, через который может быть осуществлена атака.

URL производителя: drupal.org

Решение: Установите последнюю версию 5.15 или 6.9 с сайта производителя.

Ссылки: http://drupal.org/node/358957