Переполнение буфера в DevIL

Дата публикации:
27.01.2009
Дата изменения:
26.02.2009
Всего просмотров:
1969
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DevIL 1.x
Уязвимые версии: DevIL 1.7.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "iGetHdrHeader()" в файле src-IL/src/il_hdr.c. Удаленный пользователь может с помощью специально сформированного Radiance RGBE файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: openil.sourceforge.net

Решение: Установите последнюю версию 1.7.7 с сайта производителя.

Журнал изменений:

26.02.2009
Изменена секция «Решение».

Ссылки: Secunia Research: DevIL "iGetHdrHeader()" Buffer Overflow Vulnerabilities

или введите имя

CAPTCHA