Множественные уязвимости в Amarok

Дата публикации:
26.01.2009
Дата изменения:
26.01.2009
Всего просмотров:
2392
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-0135
CVE-2009-0136
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Amarok 1.x
Amarok 2.x
Уязвимые версии: Amarok версии до 2.0.1.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Два целочисленных переполнения существуют в функции "Audible::Tag::readTag()" в файле src/metadata/audible/audibletag.cpp. Удаленный пользователь может с помощью специально сформированных Audible Audio файлов вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за двух ошибок в функции "Audible::Tag::readTag()" в файле src/metadata/audible/audibletag.cpp. Удаленный пользователь может с помощью специально сформированных Audible Audio файлов вызвать повреждение памяти и выполнить произвольный код на целевой системе.

URL производителя: amarok.kde.org

Решение: Установите последнюю версию 2.0.1.1 с сайта производителя.

Ссылки: http://trapkit.de/advisories/TKADV2009-002.txt
http://amarok.kde.org/de/node/600

или введите имя

CAPTCHA