Множественные уязвимости в playSMS

Дата публикации:
13.01.2009
Дата изменения:
13.01.2009
Всего просмотров:
2150
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PlaySMS SMS Gateway 0.x
Уязвимые версии: playSMS 0.9.3, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "gateway_module" в сценарии plugin/gateway/gnokii/init.php и в параметре "themes_module" в сценарии plugin/themes/default/init.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Пример:

http://[host]/plugin/gateway/gnokii/init.php?gateway_module=[file]
http://[host]/plugin/themes/default/init.php?themes_module=[file]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "apps_path[plug]" в сценарии plugin/gateway/gnokii/init.php, в параметре "apps_path[themes]" в сценарии plugin/themes/default/init.php и в параметре "apps_path[libs]" в сценарии lib/function.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: playsms.sourceforge.net/web/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/7687

или введите имя

CAPTCHA