Межсайтовый скриптинг в Apache Roller

Дата публикации:
12.01.2009
Дата изменения:
12.01.2009
Всего просмотров:
2017
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Roller Weblogger 2.x
Apache Roller 3.x
Apache Roller 4.x
Уязвимые версии: Apache Roller 4.0 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "q" в функционале поиска. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: roller.apache.org

Решение: Установите исправление из SVN репозитория производителя.

Ссылки: https://issues.apache.org/roller/browse/ROL-1766

или введите имя

CAPTCHA