Переполнение буфера в BulletProof FTP Client

Дата публикации:
31.12.2008
Дата изменения:
05.05.2009
Всего просмотров:
2760
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-5753
CVE-2008-5754
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BulletProof FTP Client 2.x
BulletProof FTP Client 2009
Уязвимые версии:
BulletProof FTP Client 2.63 Build 56, возможно другие версии.
BulletProof FTP Client 2009.72.0.64, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке имен сервера. Злоумышленник может заставить пользователя подключится к злонамеренному серверу, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.bpftp.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

05.05.2009
В список уязвимых приложений добавлен BulletProof FTP Client 2009, добавлен PoC код.

Ссылки: BulletProof FTP Client (.bps File) Local Stack Overflow PoC
BulletProof FTP Client 2009 (.bps) Buffer Overflow Exploit (SEH)

или введите имя

CAPTCHA