Множественные уязвимости в myPHPscripts Login Session

Дата публикации:
29.12.2008
Дата изменения:
29.12.2008
Всего просмотров:
1669
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-5854
CVE-2008-5855
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
myPHPscripts Login Session 2.x
Уязвимые версии: myPHPscripts Login Session 2.0, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "ls_user" и "ls_email" в сценарии login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточного ограничения доступа к файлу "users.txt". Удаленный пользователь может скачать файл и получить доступ важным данным приложения.

URL производителя: www.myphpscripts.net/?sid=7

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/7526

или введите имя

CAPTCHA