Множественные уязвимости в WorkSimple

Дата публикации:
22.12.2008
Дата изменения:
22.12.2008
Всего просмотров:
1986
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-5764
CVE-2008-5765
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WorkSimple 1.x
Уязвимые версии: WorkSimple 1.2.1, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за того, что файл "data/usr.txt" хранится с небезопасными привилегиями на доступ в пределах корневой директории Web сервера. Удаленный пользователь может скачать файл и получить доступ к логинами и хешам паролей пользователей.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "lang" в сценарии calendar.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/calendar.php?lang=[file]

URL производителя: www.2500mhz.info/ws

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/7481

или введите имя

CAPTCHA