Множественные уязвимости в Phpclanwebsite

Дата публикации:
19.12.2008
Дата изменения:
26.12.2008
Всего просмотров:
13813
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-5877
CVE-2008-5878
CVE-2008-5879
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Phpclanwebsite 1.x
Уязвимые версии: Phpclanwebsite 1.23.3 Fix Pack #5, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, обойти некоторые ограничения безопасности, получить доступ к важным данным и выполнить произвольные SQL команды в базе данных приложения.

1.Уязвимость существует из-за недостаточной обработки входных данных в параметре "page" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Также сообщается об уязвимостях в других параметрах. Пример:

http://[host]/index.php?page='><script>alert('XSS')</script>

2. Уязвимость существует из-за недостаточной проверки прав при выполнении некоторых действий. Удаленный пользователь может с помощью специально сформированного URL удалить произвольные учетные данные в приложении. Пример:

http://[host]/index.php?page=processforms&ok=1&SP=1&form_id=[идентификатор пользователя]

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "page" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. http://[host]/index.php?page=[SQL]

4. Уязвимость существует из-за недостаточной обработки входных данных в параметре pcwlogin сценарии index.php, когда параметр "page" равен "login" и в параметре searchvalue в сценарии index.php, когда параметр "page" равен "downloads" и параметр "func" равен "search". Удаленный пользователь может с помощью специально сформированного HTTP POST запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

5. Уязвимость существует из-за недостаточной обработки входных данных в параметре "whichfield" в сценарии index.php, когда параметр "page" равен "downloads" и параметр "func" равен "search". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

6. Уязвимость существует из-за недостаточной обработки входных данных в параметре "boxname" в сценарии /theme/superchrome/box.php и в параметре "theme" в сценарии /phpclanwebsite/footer.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена и опция register_globals включена в конфигурационном файле PHP. Также сообщается об уязвимостях в других сценариях. Пример:

http://[host]/theme/superchrome/box.php?boxname=../../../../../etc/passwd%00
http://[host]/phpclanwebsite/footer.php?theme=../../../../../etc/passwd%00

Об уязвимостях сообщил S4aVRd0w.

URL производителя: www.phpclanwebsite.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Многочисленные уязвимости в Phpclanwebsite <= 1.23.3 Fix Pack #5

или введите имя

CAPTCHA