Межсайтовый скриптинг в Drupal

Дата публикации:
16.12.2008
Всего просмотров:
1833
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 5.x
Drupal 6.x
Уязвимые версии: Drupal версии до 5.13 и 6.7

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за того, что приложение не полностью удаляет отфильтрованные входные данные. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF нападение.

URL производителя: drupal.org

Решение: Установите последнюю версию 5.13 или 6.7 с сайта производителя.

Ссылки: http://drupal.org/node/345441

или введите имя

CAPTCHA