Несколько уязвимостей в PunBB

Дата публикации:
09.12.2008
Всего просмотров:
2944
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-5433
CVE-2008-5434
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PunBB 1.x
Уязвимые версии: PunBB версии до 1.3.2

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "req_passwort" в сценарии login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости целевой пользователю должен подтвердить диалог защиты от CSRF атак.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "order_by" и "direction" в сценарии admin/users.php и в некоторых параметрах в сценарии admin/settings.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости целевой пользователю должен подтвердить диалог защиты от CSRF атак.

URL производителя: www.punbb.org

Решение: Установите последнюю версию 1.3.2 с сайта производителя.

Ссылки: http://punbb.informer.com/forums/topic/20475/punbb-132/

или введите имя

CAPTCHA