Межсайтовый скриптинг в Google Gears

Дата публикации:
09.12.2008
Всего просмотров:
1640
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Google Gears 0.x
Уязвимые версии: Google Gears версии до 0.5.4.2

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки сценариев, загружаемых с удаленных сайтов. Удаленный пользователь может выполнить произвольные Google Gears сценарии в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости злоумышленнику потребуется разместить файлы в пределах целевого домена.

URL производителя: gears.google.com/?hl=en

Решение: Установите последнюю версию 0.5.4.2 с сайта производителя.

Ссылки: http://code.google.com/apis/gears/upcoming/api_workerpool.html#cross_origin
http://lists.grok.org.uk/pipermail/full-disclosure/2008-December/066291.html
http://blog.watchfire.com/wfblog/2008/12/breaking-google-gears-cross-origin-communication-model.html

или введите имя

CAPTCHA