Уязвимость форматной строки в Vinagre

Дата публикации:
09.12.2008
Дата изменения:
11.12.2008
Всего просмотров:
2336
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Vinagre 0.x
Vinagre 2.x
Уязвимые версии: Vinagre 2.24.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки форматной строки в функции "vinagre_utils_show_error()" в файле src/vinagre-utils.c. Удаленный пользователь может с помощью специально сформированного .vnc файла выполнить произвольный код на целевой системе.

URL производителя: projects.gnome.org/vinagre/

Решение: Установите последнюю версию 0.5.2 или 2.24.2 с сайта производителя.

Журнал изменений:

11.12.2008
Добавлен PoC код.

Ссылки: Vinagre < 2.24.2 show_error() Remote Format String PoC
http://ftp.gnome.org/pub/GNOME/sources/vinagre/0.5/vinagre-0.5.2.changes
http://ftp.gnome.org/pub/GNOME/sources/vinagre/2.24/vinagre-2.24.2.changes

или введите имя

CAPTCHA