Выполнение произвольных команд в cpCommerce

Дата публикации:
01.12.2008
Дата изменения:
01.12.2008
Всего просмотров:
2199
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
cpCommerce 1.x
Уязвимые версии: cpCommerce 1.2.6, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки в сценарии _functions.php. Удаленный пользователь может с помощью специально сформированных запросов перезаписать значения произвольных переменных. Удаленный пользователь может получить привилегии администратора приложения и выполнить произвольный PHP код на целевой системе.

URL производителя: cpcommerce.cpradio.org

Решение: Установите последнюю версию 1.2.7 с сайта производителя.

Ссылки: http://cpcommerce.cpradio.org/forums/index.php/topic,3656.0.html
http://milw0rm.com/exploits/7308

или введите имя

CAPTCHA