Небезопасная обработка временных файлов в pam_mount

Дата публикации:
20.11.2008
Всего просмотров:
1716
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
pam_mount 0.x
Уязвимые версии: pam_mount 0.43, возможно другие версии.

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за того, что сценарий "scripts/passwdehd" использует временные файлы небезопасным образом. Локальный пользователь может с помощью специально сформированной символической ссылки перезаписать произвольные файлы на системе.

URL производителя: pam-mount.sourceforge.net

Решение: Установите последнюю версию 1.0 или выше с сайта производителя.

Ссылки: http://lists.debian.org/debian-devel/2008/08/msg00285.html

или введите имя

CAPTCHA