Переполнение буфера в ядре Linux

Дата публикации:
14.11.2008
Дата изменения:
18.02.2009
Всего просмотров:
1820
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel версии до 2.6.27.6

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "hfs_cat_find_brec()". Удаленный пользователь может с помощью слишком длинного имени каталога в файловой системе hfs вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.kernel.org

Решение: Установите последнюю версию ядра 2.6.27.6 с сайта производителя.

Ссылки: http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.27.6

или введите имя

CAPTCHA