Переполнение буфера в OptiPNG

Дата публикации:
12.11.2008
Всего просмотров:
1568
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OptiPNG 0.x
Уязвимые версии: OptiPNG версии до 0.6.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в компоненте чтения BMP файлов. Удаленный пользователь может с помощью специально сформированного BMP файла вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: optipng.sourceforge.net

Решение: Установите последнюю версию 0.6.2 с сайта производителя.

Ссылки: http://sourceforge.net/project/shownotes.php?release_id=639631&group_id=151404

или введите имя

CAPTCHA