Множественные уязвимости в Simple Machines Forum

Дата публикации:
06.11.2008
Дата изменения:
29.03.2009
Всего просмотров:
3922
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Simple Machines Forum 1.x
Уязвимые версии: Simple Machines Forum 1.1.6, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF нападение, установить произвольные пакеты и выполнить произвольный PHP код на целевой системе. Для удачной эксплуатации уязвимости злоумышленнику понадобиться действительная учетная запись для загрузки пакета в качестве вложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "theme_dir" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

URL производителя: www.simplemachines.org

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
29.03.2009
Изменена секция "Решение"

Ссылки: Simple Machines Forum (SMF) 1.1.6 Remote Code Execution Exploit
Simple Machines Forum <= 1.1.6 (LFI) Code Execution Exploit

или введите имя

CAPTCHA