Несколько уязвимостей в Tribiq CMS

Дата публикации:
03.11.2008
Дата изменения:
03.11.2008
Всего просмотров:
2723
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-4893
CVE-2008-4894
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Tribiq CMS 5.x
Уязвимые версии: Tribiq CMS 5.0.10a, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "template_path" в сценарии templates/mytribiqsite/tribal-GPL-1066/includes/header.inc.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "template_path" в сценарии /mytribiqsite/tribal-GPL-1066/includes/header.inc.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена и опция "register_globals" включена в конфигурационном файле PHP.

URL производителя: tribiq.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/6888

или введите имя

CAPTCHA