Межсайтовый скриптинг в CompactCMS

Дата публикации:
01.11.2008
Всего просмотров:
1934
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CompactCMS 1.x
Уязвимые версии: CompactCMS 1.1, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "pagetitle", "subheader" и "urlpage" в сценарии admin/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и удалить произвольные страницы.

URL производителя: www.compactcms.nl

Решение: Установите последнюю версию 1.2 с сайта производителя.

Ссылки: http://holisticinfosec.org/content/view/90/45/

или введите имя

CAPTCHA