Межсайтовый скриптинг в A-LINK WL54AP3 / WL54AP2

Дата публикации:
31.10.2008
Всего просмотров:
2270
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
A-LINK WL54AP2 1.x
A-LINK WL54AP3 1.x
Уязвимые версии:
A-LINK WL54AP2 версии до 1.4.2
A-LINK WL54AP3 версии до 1.4.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в имени домена. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF нападение и изменить имя и пароль администратора устройства или настройки DNS.

URL производителя: www.a-link.com

Решение: Установите последнюю версию 1.4.2 с сайта производителя.

Ссылки: http://www.a-link.com/WL54AP3.html
http://www.louhinetworks.fi/advisory/alink_081028.txt

или введите имя

CAPTCHA