Множественные уязвимости в MyBB

Дата публикации:
31.10.2008
Всего просмотров:
14983
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-4928
CVE-2008-4929
CVE-2008-4930
Вектор эксплуатации:
Удаленная
Воздействие:
Брут-форс атака
Раскрытие важных данных
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MyBB (formerly MyBulletinBoard) 1.x
Уязвимые версии: MyBB версии до 1.4.3 от 29.10.2008

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, брут-форс атаку и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "url" в сценарии moderation.php, когда параметр "action" установлен в значение "removesubscriptions" и параметр "ajax" равен "1". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости целевой пользователь должен иметь привилегии администратора или модератора.

2. Уязвимость существует из-за того, что приложение формирует имена для вложенных файлов на основе персонального идентификатора пользователя и текущего времени. Злоумышленник может произвести брут-форс атаку и получить доступ к потенциально важным данным пользователей приложения.

3. Уязвимости существуют из-за неизвестных ошибок. Подробности уязвимостей не раскрываются.

URL производителя: www.mybboard.net

Решение: Установите последнюю версию 1.4.3 от 29.10.2008 с сайта производителя.

Ссылки: http://community.mybboard.net/thread-39705.html
http://lists.grok.org.uk/pipermail/full-disclosure/2008-October/065280.html

или введите имя

CAPTCHA