Межсайтовый скриптинг в phpMyAdmin

Дата публикации:
31.10.2008
Дата изменения:
12.11.2008
Всего просмотров:
2401
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpMyAdmin 2.x
phpMyAdmin 3.x
Уязвимые версии: phpMyAdmin 2.11.9.2 и 3.0.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "db" в сценарии pmd_pdf.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.phpmyadmin.net

Решение: Установите последнюю версию 2.11.9.3 bkb 3.0.1.1 с сайта производителя.

Журнал изменений:

12.11.2008
Изменена секция «Решение»

Ссылки: http://seclists.org/bugtraq/2008/Oct/0199.html

или введите имя

CAPTCHA